Mag problems, bullet tail dives

Jan 26, 2013
234
1
18
33
Columbus, OH
#1
I just bought a few new mags as my other mags were getting old. One of the mags is having trouble feeding. The back of the round gets stuck, usually the 3rd or 4th round. This causes the bolt to not pick up the round. The other rounds feed fine. Ive checked the feed lips and they are all similar in spec to my other 5 mags.

Not sure if the follower is getting stuck or not. Any one have a solution?

 

PDXGS

Sergeant
May 31, 2009
472
13
18
Northwest Oregon
#2
Take it apart and check the follower for sprue bumps.... Sand off anything that isn't flush with the side/vertical faces.
I'd also follow up the cleaning with an application of a paraffin or Teflon based dry lube
 
Likes: diverdon
Jan 26, 2013
234
1
18
33
Columbus, OH
#3
Take it apart and check the follower for sprue bumps.... Sand off anything that isn't flush with the side/vertical faces.
I'd also follow up the cleaning with an application of a paraffin or Teflon based dry lube
Thanks forgot to mention i did that as well. Everything is smooth now as i thought it was getting caught.
 

demolitionman

POW,"no call"
Feb 26, 2013
783
52
28
Central Ohio
#5
Try bending closed the front feed lips nearest the front of the case. Doing that will hold the shoulder junction down which in turn should keep the case base up; if the follower and spring are ok.
 
Jan 26, 2013
234
1
18
33
Columbus, OH
#6
Try bending closed the front feed lips nearest the front of the case. Doing that will hold the shoulder junction down which in turn should keep the case base up; if the follower and spring are ok.
Thanks.

Tried that. My other mags spec out to .425ish. I went went down to .408 ave still the same result. My thoughts are its the spring. Its attached like a z. So most of the force is in the front of the follower. It appears you can move the spring back.. but of course who ever built this mag stripped the screws. Im wondering if on backwards. Watching the MPA video on the extended mags the spring is attached opposite. Like a bacjlkwards z, so the pressure is on the back of the follower. Ill strip down another mag tonight and double check.
 

Bradu

Full Member
Aug 24, 2011
1,382
5
38
IL
#8
I did some playing today and took the spring and follower out of an ai 308 10 round mag. It works fine with the saum rounds. I think the difference in the spring is where the problem is at. I've emailed them to get their opinion of what to do.
 

Bradu

Full Member
Aug 24, 2011
1,382
5
38
IL
#10
The accurate follower is the top one that gives me similar problems to yours, just not as bad. The bottom is an AI follower that works perfect in the accurate mag. I tried it to eliminate it being feed lips or something else. See how the spring doesn't go all the way to the back of the follower? I think that's the issue.
 
Aug 24, 2011
1,382
5
38
IL
#11
I used the contact us page and they responded almost instantly yesterday saying it was probably a chassis issue. I replied with pics showing what it is doing and told then the 3 round mag runs fine but haven't heard back since.