Atn ps15 blinking left eye?

Jul 5, 2014
135
3
18
#1
I'm leaving the upper peninsula of Michigan and its day 14 of rain and my ps15 didn't get that wet but ever since the other night they've been blinking in the left tube. It doesn't blink in complete darkness but even the slightest bit of Illumination or light makes it blink and it blinks faster and faster the more light and then turns off. I don't know if this is how the tube dies because I do use these quite a bit but.. any info would be great.
 

Surgeon_Shooter

Ancient,Free and Accepted
Mar 2, 2009
860
32
28
Louisiana
#2
There could be an issue with the power supply that is causing problems with the aitogating. It sounds like the power supply could be lowering the voltage to the micro channel plate a bit too low when it senses a high light environment. I’m sure you already have but if you haven’t, I would definitely try a new battery before I panicked. What tubes are in the 15’s?

Jay
 

compasscall

For Sale Access
Oct 22, 2011
62
2
8
RIMPAC
#9
Looks like a pair of Reed Switches for the helmet mount auto cut-off.

Appears as though the glass capsule is shattered on one of them, hard to say for certain. Those glass capsules don't take to applied force, it doesn't take much to break them.

Was the left tube having the issue before the reed switch was broken?

Though far from impossible, it's unlikely these switches are the cause of your original issue.

Insulate those bare wires and check the power going directly to the problem tube or both tubes if you like.
 
Jul 5, 2014
135
3
18
#10
When I first got the unit used it did have an auto shut-off when I tilted it up, but after a year or so that went away I didn't even notice at first. Is that what these Reed switches do? Can I just replace them with a resistor or something?